Does my tablet device need to have specific requirements for it to be compatible with the Snap Mobile Anywhere app? Do you recommend a particular brand of tablet?

The Snap Mobile Anywhere app works on the majority of tablet devices, which is why we do not recommend a particular brand of tablet for organisations to buy. Like all apps there is a minimum version requirement needed for it to work with your device. For instance, if you are using Snap Mobile on an iPad it needs to be running on iOS8 or later and for Android tablets it needs to be running on version 4.4 or later. A full specification list is provided below:

  • Apple iPad, iPhone or iPod Touch running iOS8 or later
  • Android tablets or smartphones running version 4.4 or later
  • Amazon Kindle Fire OS4 or later
  • Windows based laptops, tablets and kiosks running Windows 10, 8.x (x86/x64, not RT), 7, with Microsoft Internet Explorer version 8 or later
  • An Internet connection is required to synchronise surveys and data
  • Application uses 1024 bit RSA encryption to store data on mobile devices (AttachIt requires device level encryption)
  • Feature availability is dependent on device support.